VLAN Configuration in Mikrotik

 

Script Files Link:

https://drive.google.com/drive/folders/1p5ClgP15JoRopDAUIxum6O_27UkNG6uv?usp=sharing





ISP:

Creating VLAN:

/interface vlan

add interface=ether2-LAN name=LISP-1-VLAN-10 vlan-id=10

add interface=ether2-LAN name=LISP-1-VLAN-20 vlan-id=20

add interface=ether2-LAN name=LISP-1-VLAN-30 vlan-id=30

add interface=ether2-LAN name=LISP-1-VLAN-40 vlan-id=40

add interface=ether2-LAN name=LISP-2-VLAN-100 vlan-id=100

add interface=ether2-LAN name=LISP-2-VLAN-200 vlan-id=200

add interface=ether2-LAN name=LISP-2-VLAN-300 vlan-id=300

add interface=ether2-LAN name=LISP-2-VLAN-400 vlan-id=400




Setting IP Address into VLANs:

/ip address

add address=10.10.10.1/30 interface=LISP-1-VLAN-10 network=10.10.10.0

add address=10.10.20.1/30 interface=LISP-1-VLAN-20 network=10.10.20.0

add address=10.10.30.1/30 interface=LISP-1-VLAN-30 network=10.10.30.0

add address=10.10.40.1/30 interface=LISP-1-VLAN-40 network=10.10.40.0

add address=10.20.10.1/30 interface=LISP-2-VLAN-100 network=10.20.10.0

add address=10.20.20.1/30 interface=LISP-2-VLAN-200 network=10.20.20.0

add address=10.20.30.1/30 interface=LISP-2-VLAN-300 network=10.20.30.0

add address=10.20.40.1/30 interface=LISP-2-VLAN-400 network=10.20.40.0



LISP-1:

Creating VLAN:

/interface vlan

add interface=ether1-WAN name=VLAN-10 vlan-id=10

add interface=ether1-WAN name=VLAN-20 vlan-id=20

add interface=ether1-WAN name=VLAN-30 vlan-id=30

add interface=ether1-WAN name=VLAN-40 vlan-id=40



Setting IP address onto VLANs:

/ip address

add address=10.10.10.2/30 interface=VLAN-10 network=10.10.10.0

add address=10.10.20.2/30 interface=VLAN-20 network=10.10.20.0

add address=10.10.30.2/30 interface=VLAN-30 network=10.10.30.0

add address=10.10.40.2/30 interface=VLAN-40 network=10.10.40.0




Now we will test connectivity by Ping command


LISP-2:

Creating VLANs:

/interface vlan

add interface=ether1 name=VLAN-100 vlan-id=100

add interface=ether1 name=VLAN-200 vlan-id=200

add interface=ether1 name=VLAN-300 vlan-id=300

add interface=ether1 name=VLAN-400 vlan-id=400

Setting IP address onto VLANs:

/ip address

add address=10.20.10.2/30 interface=VLAN-100 network=10.20.10.0

add address=10.20.20.2/30 interface=VLAN-200 network=10.20.20.0

add address=10.20.30.2/30 interface=VLAN-300 network=10.20.30.0

add address=10.20.40.2/30 interface=VLAN-400 network=10.20.40.0



Now we will test connectivity by Ping command








 

Comments

Popular posts from this blog

Some Questions for MTCNA Exam

ডিপ্লোমা লেভেল এর ইন্ডাস্ট্রিয়াল এটাচমেন্ট এ আসার পূর্বে একটু ভেবে আসার অনুরোধ রইলো

Basic Router & Switch IOS commands