Internet Access from router & PC(VPCS) into GNS3

Our Target:

We want to access internet into PC

 


 

R1


[To Configure WAN side]

R1(config)# interface FastEthernet0/0

R1(config)# ip  address dhcp

R1(config)# no shutdown


[To resolve domain name]

R1(config)# ip domain-lookup

 

[To check internet connectivity]

R1(config)# do ping google.com


[To Configure LAN side]

R1(config)# interface FastEthernet1/0

R1(config)#  ip address 10.1.1.1   255.0.0.0

R1(config)# no shutdown


[To save the configuration file] 

R1(config)# do wr

 

 

R2

 

[To Configure WAN side]

R2(config)# interface FastEthernet0/0

R2(config)#  ip address 10.1.1.3 255.0.0.0

R2(config)#  no shutdown

 

[To Configure LAN side]

R2(config)# interface FastEthernet1/0

R2(config)# ip address 192.168.1.1 255.255.255.0

R2(config)#  no shutdown

 

[To set DNS server IP]

R2(config)# ip name-server 8.8.8.8


[To resolve domain name]

R2(config)# ip domain-lookup

 

[To set a route. Here we are configuring default static route]

R2(config)# ip route 0.0.0.0 0.0.0.0 10.1.1.1

 

[To check internet connectivity]

R2(config)# do ping google.com


[To configure NAT process, so that our private IP is abled to go to the internet]

R2(config)# interface FastEthernet0/0

R2(config)#  ip nat  outside

 

R2(config)# interface FastEthernet1/0

R2(config)#  ip nat  inside

 

R2(config)#ip nat  inside  source  list 1  interface FastEthernet 0/0  overload


[Here, we are giving permission only LAN-Network-192.168.1.0]

R2(config)#access-list 1 permit 192.168.1.0  0.0.0.255


[To save the configuration file] 

R2(config)# do wr

 

 

PC

[To set IP Address, Subnet Mask & Gateway]

PC2> ip  192.168.1.2/24  192.168.1.1


[To set DNS IP] 

PC2> ip dns  8.8.8.8

 

[To save the configuration file] 

PC2> save

[To Check Internet Connectivity]

PC2> ping google.com

 

Final Output:


 


Comments

  1. Red Prism Group ins one of the best Django coaching in Noida. Learn Django from industry expert with practical training, live projects and got your certificate.

    ReplyDelete

Post a Comment

Popular posts from this blog

Some Questions for MTCNA Exam

Course Content of IT Bangladesh

Networking Questions